Share
View previous topicGo downView next topic
avatar
Spritan
Spritan
Reputation:
Age:
Posts:
Registration Date:
Location:
View user profile

DB:AT opening 1(wip)

on 4/24/2015, 10:17 am
so i noticed that people moved back here -_- well that didint confuse the crap out of me or anything

well anyway ill post the same thing here as i did on the other site. im working on the opening for my series in flash...but im having lag issues when i play it in flash using ctrl+enter so the result? anywhere else the music will be desynced with the opening....i mean its synced at the beginning but following it? no just no..so what i ask is this. is there a way to get rid of the lag when i play it in flash using ctrl+enter? otherwise this is going to be a MASSIVE pain. and i dont want to just not have a opening -_-

you can see what i mean here http://www.fastswf.com/PIJEKHI so yeah.ill include a list of what sections exactly are desynced cause i feel that that may be of some use.

vegeta is supposed to get vaporized right when the music says "you waited never came!!"

the flashback to south citys destruction in episode 1 is supposed to happen right when the music says "if you were able would you go change the past...."

the image of the earth is supposed to appear when the music says "theres a furball with ONE LAST CHANCE!!!"  (speaking of which can anyone direct me to a better sprite of the earth please? i dont want to use that one if i dont have to -_-)
avatar
Administrator
Administrator
Reputation:
Age:
Posts:
Registration Date:
Location:
View user profile

Re: DB:AT opening 1(wip)

on 4/24/2015, 11:04 am
Are you setting the music to stream?
avatar
Spritan
Spritan
Reputation:
Age:
Posts:
Registration Date:
Location:
View user profile

Re: DB:AT opening 1(wip)

on 4/24/2015, 11:18 am
Rapidfir3Pho3nix wrote:Are you setting the music to stream?

no. what does setting it to stream do?

the problem is that the animation itself lags when i use ctrl+enter at certain moments. such as the view of the destroyed city and the massive explosion when south city is destroyed. it doesn't lag much during the view of the destroyed city but it still causes minor desync. and the lag at the explosion causes MAJOR desync but when i play it using ctrl+enter in flash its perfectly synced because i use that to tell how well my music is synced....meaning it ends up synced to the laggy version. im asking if there is a way to get rid of the lag when i use ctrl+enter
avatar
Administrator
Administrator
Reputation:
Age:
Posts:
Registration Date:
Location:
View user profile

Re: DB:AT opening 1(wip)

on 4/24/2015, 11:39 am
oh well maybe the resources you're using are too big or something? Also make sure you're not breaking apart BIG things like your background and stuff. That can cause a bit of lag.
avatar
Moderator
Moderator
Reputation:
Age:
Posts:
Registration Date:
Location:
View user profile

Re: DB:AT opening 1(wip)

on 4/24/2015, 12:17 pm
mountandblade77 wrote:
Rapidfir3Pho3nix wrote:Are you setting the music to stream?

no. what does setting it to stream do?

it actually syncs the swf to the audio. if it lags, it starts skipping frames to keep up. lange talks about it in this thread.

anyway, i have no idea where's the lag, i didn't really get much here, but the song is definitely not synced as you said. set the song to stream and that should be gone. as for the lag, are you trace bitmapping any backgrounds? are there any filters being used?
avatar
Spritan
Spritan
Reputation:
Age:
Posts:
Registration Date:
Location:
View user profile

Re: DB:AT opening 1(wip)

on 4/24/2015, 12:48 pm
Leo wrote:
mountandblade77 wrote:
Rapidfir3Pho3nix wrote:Are you setting the music to stream?

no. what does setting it to stream do?

it actually syncs the swf to the audio. if it lags, it starts skipping frames to keep up. lange talks about it in this thread.

anyway, i have no idea where's the lag, i didn't really get much here, but the song is definitely not synced as you said. set the song to stream and that should be gone. as for the lag, are you trace bitmapping any backgrounds? are there any filters being used?

the lag was only when i used ctrl+enter in flash. thats how i was testing the sync. so with the laggy version that is only in flash itself its synced....

anyway...THANK YOU. thanks to you telling me what stream does i was able to properly sync it to the music finally. relatively quickly infact since i had already animated everything...i just needed to add a few frames here and there link to first update everything now plays at the moment i intend it to
avatar
Spritan
Spritan
Reputation:
Age:
Posts:
Registration Date:
Location:
View user profile

Re: DB:AT opening 1(wip)

on 4/24/2015, 4:34 pm
so yeah. thanks for the help you guys!!. this will definantly speed things up for me. as a thank you ill post the completed opening on here once its finished. my youtube subs will have to wait to see the opening at the beginning of episode 2 XD
avatar
Moderator
Moderator
Reputation:
Age:
Posts:
Registration Date:
Location:
View user profile

Re: DB:AT opening 1(wip)

on 4/24/2015, 4:54 pm
no problem.

a few more things:
- bump up the audio quality. the thread i linked you to explains how to do that, bump it up to at least 120+ kbps or something. people got lots of bandwidth nowadays. if you're converting to video (which you say you will do at some point) then you can just use the max bit rate (160 kbps).
- you have some sprites in jpg as well. right-click the bitmaps and in "Compression" change it from "Photo (JPEG)" to "Lossless (PNG/GIF)"

there's some animation stuff i could talk about but it takes some more time to explain so i can do that later, if you want anyway.

good luck and keep going.

edit: try to not double post too lol
avatar
Spritan
Spritan
Reputation:
Age:
Posts:
Registration Date:
Location:
View user profile

Re: DB:AT opening 1(wip)

on 4/24/2015, 8:23 pm
Leo wrote:no problem.

a few more things:
- bump up the audio quality. the thread i linked you to explains how to do that, bump it up to at least 120+ kbps or something. people got lots of bandwidth nowadays. if you're converting to video (which you say you will do at some point) then you can just use the max bit rate (160 kbps).
- you have some sprites in jpg as well. right-click the bitmaps and in "Compression" change it from "Photo (JPEG)" to "Lossless (PNG/GIF)"

there's some animation stuff i could talk about but it takes some more time to explain so i can do that later, if you want anyway.

good luck and keep going.

edit: try to not double post too lol
i would very much like for you to talk about the animation stuff lol
avatar
Moderator
Moderator
Reputation:
Age:
Posts:
Registration Date:
Location:
View user profile

Re: DB:AT opening 1(wip)

on 4/24/2015, 9:06 pm
it's mostly just easing really
your tweens are mostly linearly spaced, as in, the space between the sprites across different frames are all even. mess around with that. remember that an ease of 100 makes things go fast then get slower gradually, and -100 is the reverse (slow, then fast).
you can also edit the easing curve if you need more control, but just that slider should suffice.

do this for character movement, camera movement, etc. it's important stuff.

here's a silly example with easing at 30 fps, and 12 fps.
here's the same example with no easing at 30 fps, and 12 fps.
View previous topicBack to topView next topic
Permissions in this forum:
You cannot reply to topics in this forum