Share
View previous topicGo downView next topic
avatar
Spritan
Spritan
Reputation:
Age:
Posts:
Registration Date:
Location:
View user profile

Random Sprite Battle 1

on 3/31/2013, 11:32 am
Random Sprite Battle 1 is a simple battle between Sonic and two of Eggman's bots I'm currently work on from time to time.

I've ran into a problem though when I recently returned to the project. For some reason when I use v_cam AS3 (Flash CS3, on a Flash CS3 document), it plays at a fixed speed, around 12 fps-not the 24 fps I want. It doesn't do this if I'm not using the v_cam though. ORlly?

I'd love to get some help on this problem, and I hope to have something to show (a preview, or the full thing, I don't really care) sometime around April or May.



avatar
Spritan
Spritan
Reputation:
Age:
Posts:
Registration Date:
Location:
View user profile

Re: Random Sprite Battle 1

on 3/31/2013, 12:21 pm
So I changed from v_cam AS3 to a custom-made v_cam AS2, changed the player (from FP9 to FP8), and file type (FCS3 to F8) to see if anything would change...no dice. :/

EDIT: Changed the player to Flash Player 9 and the animation now plays as intended! Guess I just needed to poke around a bit, that's all. Very Happy


Last edited by Yeow95 on 3/31/2013, 12:29 pm; edited 1 time in total



avatar
Spritan
Spritan
Reputation:
Age:
Posts:
Registration Date:
Location:
View user profile

Re: Random Sprite Battle 1

on 3/31/2013, 12:25 pm
There are two types of actionscript files you use when making a new project. Did you choose AS3 or AS2?






@darkdragon581 wrote:ping, i don't see you getting 'boodie' anytime soon, i don't care if your black, its most likely not going to happen
avatar
Spritan
Spritan
Reputation:
Age:
Posts:
Registration Date:
Location:
View user profile

Re: Random Sprite Battle 1

on 3/31/2013, 12:36 pm
I initially was using AS3 for the v_cam, but after reading the topic on how to create custom AS2 v_cams I whipped up a custom AS2 cam and used that instead.

So I think my entire playback problem can be traced back to me using an AS3 v_cam for my project, methinks.



avatar
Spritan
Spritan
Reputation:
Age:
Posts:
Registration Date:
Location:
View user profile

Re: Random Sprite Battle 1

on 4/1/2013, 11:45 am
Ok. It's definitely the coding in your V-Cam. Here. Download this AS3 V-Cam. It may have the proper coding for your file type.
https://www.youtube.com/redirect?q=http%3A%2F%2Fwww.sendspace.com%2Ffile%2Fir6ywy&session_token=HuYiCqO9SCTCCKK4kMDlh1MHZzN8MTM2NDg0OTA2OEAxMzY0ODM0NjY4
This way, you can still work in your AS3 project without all those changes you had to make, bro.






@darkdragon581 wrote:ping, i don't see you getting 'boodie' anytime soon, i don't care if your black, its most likely not going to happen
avatar
Spritan
Spritan
Reputation:
Age:
Posts:
Registration Date:
Location:
View user profile

Re: Random Sprite Battle 1

on 4/1/2013, 12:33 pm
@Ping wrote:Ok. It's definitely the coding in your V-Cam. Here. Download this AS3 V-Cam. It may have the proper coding for your file type.
https://www.youtube.com/redirect?q=http%3A%2F%2Fwww.sendspace.com%2Ffile%2Fir6ywy&session_token=HuYiCqO9SCTCCKK4kMDlh1MHZzN8MTM2NDg0OTA2OEAxMzY0ODM0NjY4
This way, you can still work in your AS3 project without all those changes you had to make, bro.

Thanks a bunch, although I think I'll stick with my custom v_cam AS2...unless I can edit this one.



avatar
Spritan
Spritan
Reputation:
Age:
Posts:
Registration Date:
Location:
View user profile

Re: Random Sprite Battle 1

on 4/2/2013, 2:06 pm
Hmm...turns out that neither the AS3 v_cam nor the Flash file were the culprits after all. It was always my main music set to start that was not only causing my frame rate to lag, but it was also causing my animations to lag (especially when the v_cam was moved sharply) and take a long time to load when I tested them.

On a side note, an output notification now pops up regarding multiple uses of certain song files. Will this be a problem?



avatar
Spritan
Spritan
Reputation:
Age:
Posts:
Registration Date:
Location:
View user profile

Re: Random Sprite Battle 1

on 4/2/2013, 3:26 pm
If the songs or the Flash itself isn't affected, then not really. But the fact that it was the music that started the problem makes me think what kind of file you used.






@darkdragon581 wrote:ping, i don't see you getting 'boodie' anytime soon, i don't care if your black, its most likely not going to happen
avatar
Moderator
Moderator
Reputation:
Age:
Posts:
Registration Date:
Location:
View user profile

Re: Random Sprite Battle 1

on 4/2/2013, 3:59 pm
@Yeow95 wrote:On a side note, an output notification now pops up regarding multiple uses of certain song files. Will this be a problem?

i don't really think there's a problem. i think the only thing slightly related is the fact that flash can't play many sounds all at once (stacked in different layers). the solution is simple, though. just export your audio as a single WAV file and import back again.
avatar
Spritan
Spritan
Reputation:
Age:
Posts:
Registration Date:
Location:
View user profile

Re: Random Sprite Battle 1

on 4/2/2013, 4:37 pm
@Ping wrote:If the songs or the Flash itself isn't affected, then not really. But the fact that it was the music that started the problem makes me think what kind of file you used.

Songs are .MP3, while the sound effects are .wav.



avatar
Spritan
Spritan
Reputation:
Age:
Posts:
Registration Date:
Location:
View user profile

Re: Random Sprite Battle 1

on 4/3/2013, 12:21 am
@Yeow95 wrote:
@Ping wrote:If the songs or the Flash itself isn't affected, then not really. But the fact that it was the music that started the problem makes me think what kind of file you used.

Songs are .MP3, while the sound effects are .wav.
Yeah, that's alright. If you have a problem again, just do what Leo said bro.






@darkdragon581 wrote:ping, i don't see you getting 'boodie' anytime soon, i don't care if your black, its most likely not going to happen
avatar
Spritan
Spritan
Reputation:
Age:
Posts:
Registration Date:
Location:
View user profile

Re: Random Sprite Battle 1

on 4/9/2013, 5:38 am
So I've currently preparing a 30 second preview of what I have so far. Stay tuned.



avatar
Spritan
Spritan
Reputation:
Age:
Posts:
Registration Date:
Location:
View user profile

Re: Random Sprite Battle 1

on 4/9/2013, 7:12 am
Preview is now up:



Compliments and constructive criticism is not necessary but much appreciated.



avatar
Spritan
Spritan
Reputation:
Age:
Posts:
Registration Date:
Location:
View user profile

Re: Random Sprite Battle 1

on 4/10/2013, 1:55 am
Random, yo. Lol.


I mean, it's good when you compare it to other random sonic fights, but it could have been better, you know? You got your typical sprite fight. You got the overused sound effects and SMBZ effects. It's okay, but nothing that defines what you're capable of.

But it's different, yo. It's not so bad. Keep working on it yo.






@darkdragon581 wrote:ping, i don't see you getting 'boodie' anytime soon, i don't care if your black, its most likely not going to happen
avatar
Spritan
Spritan
Reputation:
Age:
Posts:
Registration Date:
Location:
View user profile

Re: Random Sprite Battle 1

on 4/10/2013, 4:32 am
^ Thanks. I also got a similar comment about the overuse of SMBZ SFX. Need to start looking for other SFX to use...



avatar
Spritan
Spritan
Reputation:
Age:
Posts:
Registration Date:
Location:
View user profile

Re: Random Sprite Battle 1

on 4/11/2013, 1:05 am
Or I can help you create your own ; ).






@darkdragon581 wrote:ping, i don't see you getting 'boodie' anytime soon, i don't care if your black, its most likely not going to happen
View previous topicBack to topView next topic
Permissions in this forum:
You cannot reply to topics in this forum